华为HCIA实验-单臂路由

王哥哥 网络学习 265 次浏览 4条评论

拓扑图

多臂路由很浪费路由器的端口,可以用单臂,SW1的22口改成trunk,然后R1的口开子接口。子接口的名字建议和VLAN名字一样。

R1配置

<Huawei>system-view

Enter system view, return user view with Ctrl+Z.

[Huawei]sysname R1

[R1]int g0/0/1.200        //开子接口,编号可以随意,我们为了区分方便

[R1-GigabitEthernet0/0/1.200]dot1q termination vid 200        //接口封装了VLAN ID,需要打VLAN Tag

[R1-GigabitEthernet0/0/1.200]ip add 192.168.20.1 24

[R1-GigabitEthernet0/0/1.200]arp broadcast enable        //使能终结子接口的ARP广播功能,系统会构造带Tag的ARP广播报文。如果不打开,系统会丢弃该IP报文。

 

[R1-GigabitEthernet0/0/1.200]int g0/0/1.100

[R1-GigabitEthernet0/0/1.100]dot1q termination vid 100

[R1-GigabitEthernet0/0/1.100]ip add 192.168.10.1 24

[R1-GigabitEthernet0/0/1.100]arp broadcast enable

 

[R1]dis ip routing-table        //验证路由器的路由

SW1配置

<Huawei>system-view

[Huawei]sysname SW1

[SW1]vlan batch 100 200

 

[SW1]interface Ethernet 0/0/1

[SW1-Ethernet0/0/1]port link-type access

[SW1-Ethernet0/0/1]port default vlan 100

 

[SW1]interface Ethernet 0/0/2

[SW1-Ethernet0/0/2]port link-type access

[SW1-Ethernet0/0/2]port default vlan 200

 

[SW1]int e0/0/22

[SW1-Ethernet0/0/22]port link-type trunk

[SW1-Ethernet0/0/22]port trunk allow-pass vlan 100 200

 

[SW1-Ethernet0/0/22]dis port vlan active

PC配置

测试

4条评论

  1. 四月的奥德赛 2020年9月22日 下午3:36

    子接口 现在都没这种东西了

    • 王哥哥 2020年9月22日 下午3:44

      谁说没有子接口的 你又乱说了

      • 四月的奥德赛 2020年9月27日 上午6:58

        单臂路由 学校的时候就学了。后来企业里面根本没人用单臂路由的。

        • 王哥哥 2020年9月27日 上午10:21

          我们说子接口有人用 又没说单臂路由

发表评论

Go